Claris Connect

Using Claris Connect with your
FileMaker data.

Introducing Claris Connect.

Claris Connect™ is a cloud-smart workflow automation platform that allows you to
create entire workflows by connecting applications and services together. Claris
Connect is built on the concept of flows, used to automate everyday business tasks and
processes. Flows are automations that use two or more components. A component can
be a Claris Connect utility or a connector to a third-party application or service.

Connecting to your FileMaker data using connectors.

Besides providing connectivity and integration with popular third-party applications and
services, Claris Connect provides connectors to easily integrate with the data in your
FileMaker apps.

These connectors include support for:

. Claris FileMaker Cloud® 2.18.x
. Claris FileMaker Cloud for AWS 1.18.x
. Claris FileMaker™ Server 18.0.3

Also, if your FileMaker Server resides in a secure location without a direct Internet
connection, an on-premise agent is available as a gateway to provide access to your
FileMaker data.

This document provides steps on how to enable FileMaker apps to integrate with web
apps and services using Claris Connect. Topics include:

e Using the FileMaker Cloud and FileMaker Server connector
e Using the FileMaker Server on-premise connector
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The initial step in any flow is a trigger, an event that initiates a flow. Subsequent steps in
a flow are actions. After you create and enable a flow, each time the trigger event
occurs, Claris Connect automatically performs the flow.

Below is a table representing what FileMaker connectors support:

Connector type Can be.used asa Canbe us.ed asan
trigger action
FileMaker Cloud X X
FileMaker Server (host via the Internet) X X
FileMaker Server on-premise X

General considerations when connecting to your
FileMaker data.

Regardless of the method you are using to connect to your FileMaker data, some
general considerations are essential to understand:

e  Claris Connect supports and requires FileMaker ID. The FileMaker ID integrated
sign-on system authenticates Claris Connect users and users of FileMaker apps
hosted by FileMaker Cloud.

. Your data needs to be accessible / hosted on the Internet. The exception are
FileMaker Server and MySQL instances behind a firewall using the appropriate
on-premise agent from Claris.

e You must enable support for the FileMaker Data API on the server (FileMaker
Cloud and FileMaker Server) you are accessing.
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e Your FileMaker app(s) need to have the FileMaker Data API extended privilege
(fmrest) enabled.

e Avalid, 3rd-party SSL certificate must be used on the server you are trying to
access. The default certificate that comes with FileMaker Server does not satisfy
the SSL certificate requirement.

Using the FileMaker Connectors.

The behavior, functionality and configuration of the FileMaker Cloud and FileMaker
Server connectors are similar.

Both the FileMaker Cloud and FileMaker Server connectors can be used as a trigger or
action in your flows.

Supported triggers Supported actions

Create record
Edit record

Get record by ID
Delete record
Search record
Execute script

e Script trigger

Configuring the FileMaker Cloud and FileMaker Server connector.

Before you can use either the FileMaker Cloud or FileMaker Server connector as a
trigger or an action in a flow, you must first connect to your FileMaker app.

The information you are required to provide differs depending on the connector you are

configuring. Below is an example of both connectors and the information you need to
provide:

Page 3 of 17



Connecting to FileMaker Cloud Connecting to FileMaker Server

FileMaker Cloud FileMaker Server 18v3
Allow Claris Connect to access your FileMaker Cloud account? Allow Claris Connect to access a database on FileMaker Server
18v3?
i IEE :na;zduz)mam.com
-cloud.com L;l;r:r,\,
Information needed: Information needed:
e Organization e Domain (DNS name)
e Instance e Username
e Database e Password
(]

Database (extension optional)
Because FileMaker Cloud and Claris

Connect utilize FileMaker ID, you are This information will have to be typed in
automatically authenticated. You do not manually.

need to specify login credentials.

Once connected, you can use either the FileMaker Cloud or FileMaker Server connector
as either a trigger or an action.

Using the FileMaker connectors as a trigger.
Setting up either the FileMaker Cloud or FileMaker Server connector to be used as a
trigger requires that you make simple modifications to your hosted FileMaker app, which

include building a script. Familiarity with JSON is recommended when setting up
FileMaker Cloud or FileMaker Server as a trigger.

It is beyond the scope of this document to provide detailed assistance in writing
properly-formatted JSON.

When you add the FileMaker Cloud or FileMaker Server connector as a trigger, the
configuration directions are displayed on-screen, including a special URL known as a
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callback URL. Make a note of this callback URL as it is needed when setting up either
connector as a trigger.

Edit History Settings Versions

Select > Action > Account > Configure

Setup your callback url

Using a FileMaker Pro Advanced script trigger with Claris Connect

CURL Info = options o "request POST

Callback URL ==l https://0ikOh}.apps.connect.claris.com/api/hooks/v1/catch/filemaker_cloud/koQiR15w

To configure either the FileMaker Cloud or FileMaker Server connector as a trigger,
follow these summarized steps:

1. In FileMaker Pro Advanced, open the Script Workspace and create a new script.
The script can be named anything you want.

2. Add a Set Variable step to your script. Name the variable $$JSONdata. Set the
Value of the variable to “{\"action\":\"script\"}".

@® "Set Variable" Options

Names prefixed by “$" are local variables available only within the
current script. Prefix the name with “$$" to make the variable available
throughout the current file (global).

Name: | $$JSONdata

Value: "{\"action\":\"script\", Specify...
Repetition: 1 Specify...
Cancel (IS

Add any data you want to send to Claris Connect into the $$JSONdata variable
formatted as JSON key pairs. Make sure not to change the “action” property when
doing so.
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3. Add anInsert from URL step to your script using the following parameters:

Script option Description
With dialog Off
Specify URL The callback URL that is provided /

displayed as part of the FileMaker Cloud
connector instructions (see above.)

This URL is unique to this flow and should
not be used in other flows as a trigger.

Specify cURL The cURL information provided / displayed
options as part of the FileMaker Cloud connector
instructions (see above.)

This information will be the same for all
flows that use the FileMaker Cloud
connector as a trigger.

Here is an example of what the script might look like:

@® [ ] Script Workspace (contacts (mysamplecloud))
+ K w00

My Sample Script *

1 Set Variable [ $$]SONdata ;
Value: "{\"action\":\"script\", \"example\":\"" & contacts::Postal Code & "\"}" ]

2 Insert from URL [ Select ; With dialog: Off ;
"https://cwiz@s.apps.connect.claris.com/api/hooks/v1/catch/filemaker_cloud/LpnQjKTP" ; cURL options:
"—-request POST —-header \"Content-Type:application/json\" --data @$$JSONdata" ]

4. Save the script and exit the Script Workspace.
5. Create a script trigger on the desired layout to run your saved script. When
executed, the script sends the data defined in Step 2 to Claris Connect.
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While the on-screen directions specify the use of a script trigger, a manually executed
script or a script attached to a button will work just as well.

Using the FileMaker Cloud or FileMaker Server connector as an action.

Using the FileMaker Cloud or FileMaker Server connector as an action in your flows is
straightforward. Begin by selecting a supported action you want to perform and click
Continue.

My Projects My Project > My Flow

% Flows
Edit History Settings

Approvals

Nebhook
@ 1 New Subscriber ®

Sharing

You are prompted to choose a layout within your FileMaker app. Only the fields that are
on the selected layout are available for use in your flow.
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# MyProjects My Project > My Flow

B3 EED Edt  History  Settings  Versons  JDosbed

© Approvals

& Webhooks

@ 1 New Subscriber ®
Sharing

n Create record W
Select > Action > Account > Configure
Layout R Test
Layout name
contacts v X

@ 1 Mailchimp (sample Audience) New Subscriber

v body
type  subscribe
firedat  2020-03-0416:28:24
v data
id 871972136

email

email_type

ipopt 17184103191

Name

Consider creating a special layout in your FileMaker app with only the fields that you
want available to your flow(s).

At this point, you can access step data from previous steps to interact with your
FileMaker app.

Using the FileMaker Server on-premise connector.

Use the FileMaker Server on-premise connector when accessing data that is behind a
firewall or otherwise not connected to the Internet. The current version of Claris
Connect provides on-premise connectors for:

. FileMaker Server 18.0.3 (or later)

This document only covers how to configure and use the FileMaker Server on-premise
connector.

The FileMaker Server on-premise connector only supports being used as an action in a
flow:
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Supported triggers Supported actions

Create record
Edit record

Get record by ID
Delete record
Search record
Execute script

e None / Not supported at the time

Installing the FileMaker Server On-premise connector.

Before you can use the FileMaker Server on-premise connector as part of a flow, the
agent must be downloaded and configured.

From the Claris Connect Homepage, click the Options menu next to your team name
(displayed at the top left) and select Add On-premise Agent.

FileMaker, Inc. -

My Projects

The Add On-premise Agent wizard appears and walks you through creating a unique,
user-defined agent name as well as prompting you to select the version of the on-
premise agent you want to download before clicking Next.
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FileMaker, Inc. -

My Projects  Templates

Add On-Premise Agent

Enter Name and OS

Agent name
Enter a unique name for the agent.

MyAgent

The agent key is displayed. The agent key is used during the installation of the on-
premise agent and when using the on-premise agent in a flow. Click Download
Installer to download the selected agent installer.

FileMaker, Inc. -

My Projects ~ Templates ~ On-Premise Agents

Add On-Premise Agent

Accept Terms Download the Installer
Enter Name and OS
@ Install

Aself-ext le file will be installed.

Agent Key
Copy this key and paste it when prompted by the installer.

M1X46HA-NANMCOH-MR406J7-E61FRPP Copy.

Finish installation to set up the agent connection.

Navigate to your Downloads folder and copy and run the installer on the machine
where you want to install the on-premise agent.

Unless you have a reason to change it, accept the default installation location of the
agent, and click Next.
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@ Setup

Install Directory (())

Enter the directory where the agent will be installed.

Install Directory ||/Library

Cancel < Back Next >

You do not need to install the on-premise agent on the same machine where your
FileMaker Server is located. The on-premise agent can be installed on a different

machine as long as that machine has access to the Internet AND access to the
machine where your on-premise data resides.

Port 443 should be available for outgoing traffic on the machine where the agent is
installed.

Next, the agent installer prompts you to enter the agent key you received earlier.
@® Setup

Agent Key (())

Provide the agent key provided in Connect.

Agent Key FHSNZ1R—VM44FNK—HBZQ647—MSVAPP2|

Cancel < Back Next >
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You can retrieve the agent key at any time by accessing the On-premise Agents tab
and selecting the desired agent from the list of agents.

Working with the configuration.yml file.

A configuration.yml is created in the installation folder as part of the installation of the
on-premise agent. It includes four default fields and information generated by the
installer. An example of a default configuration.yml file is shown below:

name: Bedford Falls

id: 7c2f37ca-854e-4564-8705-24c2e08846a0
team: 58ecd75244b1ed4406592e666

host: 'https://localhost:3000'

= W N

In most cases, this default information should not be altered or changed. However,
additional fields and information about the data sources you wish to connect to should
be added to the configuration.yml file before running the agent, including:

Field name Description
Connector name This will either be “mysql” or “filemaker”
depending on the type of agent you are
configuring.

A configuration.yml can contain
information about both types of agents,
as shown in the example below.
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Field name

Description

Connection name

Host (MySQL) or Domain (FileMaker)

User (mySQL) or username (FileMaker)

Password

Database
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A connection name identifies an instance
of the connector.

The connection name can be named
anything you want it to be. It is
recommended that spaces not be used in
your connection name(s).

Each named connection has its own
namespace. Therefore, for each
connector, you can have multiple named
connections to different databases or
data sources.

In the example below, note that bailey-
park and night-machine are two
connection names under the connector
name of filemaker.

The IP address of the MySQL host, or the
URL of the FileMaker domain.

In most cases, encapsulate your host or
domain names in single quotes. For
example:
‘https://my.domain.com’

The database user name.

Usernames should be entered using the

same case as defined in your FileMaker
app or MySQL source.

For MySQL, the password for the host
computer. For FileMaker, the password
for the database.

The database name (optional for mySQL.)
Database names are case sensitive.

Use of database extensions (ex: .fmp12)
are optional.


https://my.domain.com'

Below is an example of a properly configured configuration.yml file.

l: name: Bedford Falls

2: id: 7c2f37ca-854e-4564-8705-24c2e08846a0
3: team: 58ecd75244bled4406592e666

4: host: 'https://localhost:3000'

5: mysql:

6: pottersville:

7: host: 127.0.0.1

8: user: potter

9: password: BankLOan$

10: database: finance

11: filemaker:

12: bailey-park:

13: domain: ‘https://examplel.com’
14: username: bailey

15: password: 0dBOdy!

16: database: angels

17: night-machine:

18: domain: ‘https://example2.com'
19: username: watson

20: password: s@mple

21: database: assets

Tips for editing the configuration.yml file:

e Spacing is important. Do not use tabs when indenting values. Instead, use 2

spaces and 4 spaces when appropriate.

e Use single quotes around domain URLs and other values that might have

spaces and/or special characters in them.

Configuring the on-premise agent from the command line.

An on-premise agent remains inactive until you start it. Claris Connect provides a
command-line utility to run and manage an agent. To see the available commands, open

a terminal window in the installation folder and type:
agent --help

Claris Connect supports the following commands:
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Command Description

version Returns the current version of the installed agent.
update Updates the configuration file.

decrypt string Decrypts credentials for use in the configuration file.
encrypt string Encrypts credentials for use in the configuration file.

configure key Generates a new configuration file, overwriting the previous one.

run Runs the agent, using the current configuration file.
start Starts the agent as a service, using the current configuration file.
stop Stops the currently running agent service.

To begin using the agent, open a command-line / terminal window and type in the
following command:

agent start

You can confirm the status of your configured agents by clicking the On-premise
Agents tab on the Claris Connect Homepage. Active agents are listed as “Active.”

FileMaker, Inc. -+

My Projects ~ Templates ~ On-Premise Agents

The Options menu for an agent allows you to delete it or retrieve the agent key.
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Using the FileMaker Server on-premise connector in a flow.
You can use active agents in your flows.
When you use an on-premise agent for the first time, you need to specify what agent

you want to use by specifying the agent key and the connection name as defined in the
configuration.yml file.

# Myprojects My Project > My Flow
% Flows

@ Approvals
& Webhooks
®
2 Sharing .
Server On-Premi g
Allow Claris Connect to access your FileMaker Server On-Premise
“ account? {

AgentKey

‘Connection Name

night-machine *

ﬁ

Claris Internationalinc.  Privacy Policy ~ Terms of Service | Documentation Help

After you have successfully connected to the agent, specify the layout in your FileMaker
app that you want to use. Only the fields that are on the selected layout are available for
use in your flow.

Q search

@ 1. Mailchimp (Sample Audience) New Subscriber -

Cuan  cucuuous 102024

In some cases, it might make sense to create a special layout in your FileMaker app
with only the fields that you want available to your flow(s).



Summary

Claris Connect provides powerful integration between your hosted FileMaker apps and
the applications and services you use every day. Whether you want data from a web
form seamlessly entered into your FileMaker app or the same data sent to your favorite
online service, Claris Connect provides the power and flexibility to make that happen —
all in a simple to use point-and-click interface.

Legal information

© 2020 Claris International Inc. All rights reserved.

Claris International Inc.
5201 Patrick Henry Drive Santa Clara, California 95054

FileMaker, FileMaker Cloud, FileMaker Go and the file folder logo are trademarks of
Claris International Inc. , registered in the U.S. and other countries. Claris, the Claris
logo, Claris Connect, and FileMaker WebDirect are trademarks of Claris International
Inc. All other trademarks are the property of their respective owners.

Claris product documentation is copyrighted. You are not authorized to make additional
copies or distribute this documentation without written permission from Claris. You may
use this documentation solely with a valid licensed copy of Claris software.

All persons, companies, email addresses, and URLs listed in the examples are purely
fictitious and any resemblance to existing persons, companies, email addresses, or
URLs is purely coincidental. Product credits are listed in the Acknowledgments
documents provided with this software. Documentation credits are listed in the
Documentation Acknowledgments. Mention of third-party products and URLs is for
informational purposes only and constitutes neither an endorsement nor a
recommendation. Claris International Inc. assumes no responsibility with regard to the
performance of these products.

For more information, visit our website at https://www.claris.com.
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